No side effects, no surprises.

Prerequisites

Language

The V language per se does not have any prerequisites: its regular grammar, syntax and semantics are separate and distinct from any other computer language.

As of 2011, the V language is not subject to any standards or proposed standards.

V Language Interpreter

The V Language Interpreter however, does have prerequisites. The initial development platform for the VLI was Fedora 14. The initial target operating system was Linux.

Any RedHat flavor of Linux, including CentOS and Fedora, should work reasonably well. Debian and Ubuntu will need some work in order to accommodate the differences between the systemd and SysVInit service architectures. Mac OSX, Solaris, and BSD have not been tested and will need even more work than Debian or Ubuntu. No work has been done towards Windows server compatibility.

PHP

The VLI runtime has been developed using the PHP interpreted language, and PHP has been ported to run on many of these systems. Conceptually, much of the VLI could be used as is on untested OSs.

The VLI runtime was developed using PHP CLI (common language interface) version 5.3.5, and should therefore work on hosts with similar PHP versions.

The CGI version of PHP (the web module) is not a prerequisite.

Root

VLI should be run using a Linux account that has root group permissions. VLI needs this permission in order to traverse directories and inspect file attributes and network settings. VLI does not need to run as the root user itself.

Plugin module prerequisites

VLI plugin modules make use of additional system packages and are therefore dependent upon specific versions of those packages. As a general rule, the third-party developer of a plugin module should provide a statement listing the packages and versions that are required when using those plugins.